分类存档: 原创 - 第9页

fedora/linux升级firefox/fedora13安装新版本firefox

fedora官方的firefox的rpm/yum安装包更新非常慢,远远滞后于firefox的升级步骤。拿目前(2010-08-29)的版本来看,firefox最新版本是3.6.8,但yum上,版本只更新到了3.6.3.
虽然firefox的最近几个子版本号更新并没太大的改动,使用上没有感觉到有什么不同之处,不过对于“新版本升级爱好者”来说,升级到最新版本心里会感觉顺畅一些。
完美的升级firefox,是一件很麻烦的事情。
从firefox官方下载升级包,解压缩到rpm安装位置/usr/lib/firefox-3.6,如果没有启用selinux,可以正常使用(解压缩到其它目录里也是一样可以正常运行,但这样会有两个版本的firefox,有点洁癖~~);但如果selinux运行,会提示错误:libxul.so无权限。因为对selinux并不熟悉,掏腾一下,没有搞定。
阅读全文——共3301字

php在windows2003/IIS下安装php程序运行错误“您未被授权查看该页”

核心:给php安装目录赋上users组读与执行权限
环境:新安装服务器,windows2003/iis,windows安装目录C盘的权限设置很严格,很多没有必要的的用户权限都删掉了。配置phpphp文件解压缩到c:\php5;设置系统变量:path增加c:\php5,新建一个系统变量PHPRC值为c:\php5;拷一个配置好的php.ini文件到c:\php5;iis站点里设置php文件映射,新增加isapi.dll的web服务扩展,并设置为启用状态;重启windows;
然后,运行一个phpinfo.php的测试文件(文件内容为<%php phpinfo(); %>),用以检测安装是否正确。但很奇怪的是出现“您未被授权查看该页”的错误。突然想起来,要对pho.ini设置web站点用户的读与执行权限,于是赶快给php.ini文件赋iis_web组的读与执行权限。再执行,还是看到“您未被授权查看该页”错误页。单独对iis站点用户赋权限也还是不行。[注]iis_web组是所有web站点用户的组,没有赋什么特殊权限,只对各自iis站点目录赋相应权限。这也是“最小权限”原则。
阅读全文——共1146字

apache/重装windows后如何修复apache2,并注册为系统服务

一般来说首次安装apache时建议安装到非windows系统所在分区,这样在windows崩溃重装后,可以不用再次进行“安装配置apache”这样重复性工作,而是直接重新注册apache为系统服务就很可以了。
这里讲一下apache重新注册为系统服务的方法(这里以apache2.0.55 win32版为例说明)。
软件的说明文档是很有用的东西,比用google在无数的结果里找寻更更准确;当然,很多软件——尤其是自由软件free software——多是英文文档,因此直接看文档常常会有一些难度。笔者的E文也不好,看还是尽量看一些英文文档,个人认为这是很有用的。
apache安装目录里有bin/目录,apache的可执行程序就在这里,里面最主要的就是Apache.exe (某些版本可能是httpd.exe)
阅读全文——共2087字

linux下如何卸载google earth

运行google earth安装目录下的uninstall就可以了,当然要使用有权限的用户,如root登录,su切换到root,sudo命令

google earth linux无法运行:OpenJDK Runtime Environment (IcedTea6 1.7.1) (fedora-37.b17.fc13-i386) OpenJDK Server VM (build 14.0-b16, mixed mode)

使用fedora 13 Linux,安装google earth,安装后却无法运行,解决过程手记。
系统环境,fedora13,内核版本为 2.6.31.5-127.fc12.i686(是fedora12的内核,因为新版本内核对显示支持有问题,用新版本内核自己编译也是一样,于是用fedora12里的老版本内核了),安装时,只选择了一部分自己觉得有必要的有安装,而并没选择其它过多的软件包。
安装google earth时选择的安装位置选择为/usr/local/而不是默认的/opt/,安装后无法运行,有selinux报错,由于对selinux并不熟悉,于是修改selinux为只报告,并不阻拦。然后在命令行里运行,又看到错误消息:具体消息没有记下来,最后两行大概是这个样子:
阅读全文——共14565字

wordpress 3.0.1终于出中文版了,支持并感激汉化工作者~~

刚才进入wordpress控制板,看到3.0.1中文版出来了,终于出来了,二话不说马上,autoupdate,使用美国主机,自动升级速度非常快,不像之前使用天朝网络里的服务器主机那样,十次升级,9次都要超时。重新载入页面后,控制板里的文字都成中文了,不像之前那样半中半英的了。
从3.0到现在,wordpress终于中文版了,可能是汉化工作者最近一直比较忙,没来得及,现在终于不负广大wp支持者的厚望出了中文版,感谢

ECSshop安装,安装过程中无法连接到数据库

ECSshop安装,安装过程中,数据创建可以完成,但到最后有个“无法连接到数据库”的提示。数据库服务器地址是用域名的,改为IP地址,问题解决

UE/US正则表达式查找搜索替换,查询的字符串未找到(UE studio/ultraEdit)/修改UE使用Perl正则引擎

UE默认使用UltraEdit正则表达式,就是UE自己改造过的正则语法,跟常用的perl兼容正则表达式语法不一致,所以即使写对了正则表达式,还会显示“查询的字符串未找到”。这就需要修改UE的正则引擎为Perl引擎,方法如下:在crtl+f,在“查找”对话框里点右下角的“高级”按钮,下面长出来部分的“正则表达式引擎”勾选perl,即可以。如下图所示:

[附注] 网上有文章如是说——————————–用UltraEdit打开文本,首先到菜单中选择正则表达式引擎,正则表达式引擎分支位于“配置 – 搜索”之下,有如下选项:
阅读全文——共731字

wordpress 3.0.1开启多用户功能的具体操作方法步骤 (Warning: An existing WordPress network was detected./wp-config.php配置“above the line reading /* That’s all, stop editing! Happy blogging. */:”)

wordpress 3.0版本整合了多用户功能,但没有默认启用,需要手工配置。3.0刚出来时看控制板里没有启用多用户的选项,就没有查询启用方式。今天——其实是昨天了——比较无聊,想起这茬儿,于是查一个具体怎么启用。
在一个专用于测试的wordpress上操作,该wordpress已经升级到3.0.1,并安装有2.9.x的汉化包(3.0以来没有中文汉化出来,因此有一部分文字显示为英文)。没有启用“固定链接”(伪静态)。
google一下,很多篇相关文章,多数都是从这里转载的
http://www.bokezhuanqian.com/how-to-open-multi-user-in-wordpress-3-0/
阅读全文——共3765字

fedora 12/13/14 安装五笔输入法 及 yum查找所需软件包yum provides使用

新安装fedora13,跟以前版本一样,里面没有自带五笔输入法,中文输入法只有一个拼音,难道现在用五笔的人就那么少吗?!
以前安装五笔都是网上查安装fedora下yum 安装五笔的命令直接运行,根本没有记住,更不知道怎么通过yum查找需要软件包的方法。于是想探索一下yum查询命令的使用。
最开始直接使用yum install ibus-wubi,看五笔包是不是叫ibus-wubi,结果
No package ibus-wubi available.
阅读全文——共8162字

Pages: Prev 1 2 3 4 5 6 7 8 9 10 11 12 13 Next